ERROR 2853

Moderator: NorbertKrupa

Post Reply
ncreekmur
Beginner
Beginner
Posts: 29
Joined: Tue Oct 23, 2012 3:56 pm

ERROR 2853

Post by ncreekmur » Tue Oct 23, 2012 4:31 pm

"Could not execute user procedure: fork error "

Encountered this error on two separate stored procedures we have scheduled to fire from cron jobs overnight.

I've been able to re-execute these by hand this morning, so it doesn't appear to be an issue in the VSQL.

Can anyone share any insight into this error, how to troubleshoot, and possible steps to rectify the issue?

Thanks,
Nick

User avatar
JimKnicely
Site Admin
Site Admin
Posts: 1768
Joined: Sat Jan 21, 2012 4:58 am
Contact:

Re: ERROR 2853

Post by JimKnicely » Wed Oct 24, 2012 1:37 am

Hi,

I wonder if this is an issue where you are exceeding the max processes?

On my system:

Code: Select all

[root@vertica01 ~]# ulimit -u
606208

[root@vertica01 ~]# cat /proc/sys/kernel/threads-max
1212416

[root@vertica01 ~]# cat /etc/security/limits.conf | grep -i nproc
#        - nproc - max number of processes
#@student        hard    nproc           20
#@faculty        soft    nproc           20
#@faculty        hard    nproc           50
#ftp             hard    nproc           0
What is the out put on your system?
Jim Knicely

Image

Note: I work for HPE. My views, opinions, and thoughts expressed here do not represent those of my employer.

ncreekmur
Beginner
Beginner
Posts: 29
Joined: Tue Oct 23, 2012 3:56 pm

Re: ERROR 2853

Post by ncreekmur » Wed Oct 24, 2012 9:45 pm

Glad to share.

Code: Select all

[root@vertica01 ~]# ulimit -u
1024
[root@vertica01 ~]# cat /proc/sys/kernel/threads-max
1547434
[root@vertica01 ~]# cat /etc/security/limits.conf | grep -i nproc
#        - nproc - max number of processes
#@student        hard    nproc           20
#@faculty        soft    nproc           20
#@faculty        hard    nproc           50
#ftp             hard    nproc           0
dbadmin soft    nproc   96732
dbadmin hard    nproc   96732
Thanks for the help.

id10t
GURU
GURU
Posts: 732
Joined: Mon Apr 16, 2012 2:44 pm

Re: ERROR 2853

Post by id10t » Thu Oct 25, 2012 8:09 am

Hi!

Probably the problem with maximum number of open files (ulimit).
See :
1.Verify that Kernel and User Parameters Were Set
2.Increase the Maximum Number of Files Open
3.Increase the max_map_count Parameter

ncreekmur
Beginner
Beginner
Posts: 29
Joined: Tue Oct 23, 2012 3:56 pm

Re: ERROR 2853

Post by ncreekmur » Thu Oct 25, 2012 6:10 pm

We were missing the fs.file-max setting in our sysctl.conf file, but had open file limit set up correctly in a few other ways according to our sys admin.

At any rate, is adding that parameter going to make a difference in some substantial way if we had it covered from somewhere else, or does it perform a unique function?

Thanks!

Post Reply

Return to “Vertica Error Codes”