Eliminating the ssh client timeout

Moderator: NorbertKrupa

Post Reply
User avatar
fsalvelt
Intermediate
Intermediate
Posts: 54
Joined: Sun Mar 18, 2012 1:34 am

Eliminating the ssh client timeout

Post by fsalvelt » Mon Jun 24, 2013 2:27 pm

Hi guys,

I am connecting to my Vertica Linux host via putty in Windows. Is there a way in Linux I can eliminate the inactivity timeout period? Or at least set it to something longer?

Thank you!
Thank, Fred

User avatar
JimKnicely
Site Admin
Site Admin
Posts: 1806
Joined: Sat Jan 21, 2012 4:58 am
Contact:

Re: Eliminating the ssh client timeout

Post by JimKnicely » Mon Jun 24, 2013 2:40 pm

HI,

You should be able to set a timeout on a user by user basis with the TMOUT environment variable set in the ~/.bash_profile.

Example (for 15 minute timeout):

export TMOUT=900

Or, for everyone, modify the following settings in the /etc/ssh/sshd_config file.

Example (for 15 minute timeout):

ClientAliveInterval 900
ClientAliveCountMax 0
Jim Knicely

Image

Note: I work for Vertica. My views, opinions, and thoughts expressed here do not represent those of my employer.

Post Reply

Return to “Vertica and the Operating System”