Error while creating database in a 3-node cluster.

Moderator: NorbertKrupa

Post Reply
Nithesh
Newbie
Newbie
Posts: 1
Joined: Tue Aug 02, 2016 1:46 pm

Error while creating database in a 3-node cluster.

Post by Nithesh » Tue Aug 02, 2016 2:22 pm

Hi,

I am using Vertica community edition 7.2.3 and am setting up a 3-node cluster on AWS VPC.
My install_vertica script runs fine. While creating the database, the node from where i am issuing the command via adminTools comes up but rest of the two nodes stay down.

Code: Select all

 Node Status: v_mpp_test_node0001: (DOWN) v_mpp_test_node0002: (UP) v_mpp_test_node0003: (DOWN)
All the requisite ports as per 'my.vertica.com/docs/Ecosystem/Amazon/HP_Vertica_7.1.x_Vertica_AWS.pdf' are open.
There exists an password less ssh between the 3-servers.

following is the netstat output:

Code: Select all

[root@ip-10-0-3-xxx ec2-user]# netstat -an | egrep 'tcp|udp'
tcp        0      0 10.0.2.185:4803             0.0.0.0:*                   LISTEN
tcp        0      0 0.0.0.0:5444                0.0.0.0:*                   LISTEN
tcp        0      0 0.0.0.0:36582               0.0.0.0:*                   LISTEN
tcp        0      0 0.0.0.0:111                 0.0.0.0:*                   LISTEN
tcp        0      0 0.0.0.0:22                  0.0.0.0:*                   LISTEN
tcp        0      0 127.0.0.1:631               0.0.0.0:*                   LISTEN
tcp        0      0 0.0.0.0:5433                0.0.0.0:*                   LISTEN
tcp        0      0 127.0.0.1:25                0.0.0.0:*                   LISTEN
tcp        0      0 0.0.0.0:5434                0.0.0.0:*                   LISTEN
tcp        0      0 10.0.2.185:22               10.0.200.5:53124            ESTABLISHED
tcp        0      0 10.0.2.185:5434             10.0.2.185:36504            ESTABLISHED
tcp        0      0 10.0.2.185:36504            10.0.2.185:5434             ESTABLISHED
tcp        0      0 :::111                      :::*                        LISTEN
tcp        0      0 :::22                       :::*                        LISTEN
tcp        0      0 ::1:631                     :::*                        LISTEN
tcp        0      0 :::5433                     :::*                        LISTEN
tcp        0      0 ::1:25                      :::*                        LISTEN
udp        0      0 0.0.0.0:111                 0.0.0.0:*
udp        0      0 0.0.0.0:631                 0.0.0.0:*
udp        0      0 10.0.2.185:123              0.0.0.0:*
udp        0      0 127.0.0.1:123               0.0.0.0:*
udp        0      0 0.0.0.0:123                 0.0.0.0:*
udp        0      0 0.0.0.0:33666               0.0.0.0:*
udp        0      0 0.0.0.0:935                 0.0.0.0:*
udp        0      0 10.0.2.185:5433             0.0.0.0:*
udp        0      0 10.0.2.185:4803             0.0.0.0:*
udp        0      0 10.0.2.185:4804             0.0.0.0:*
udp        0      0 0.0.0.0:68                  0.0.0.0:*
udp        0      0 0.0.0.0:42327               0.0.0.0:*
udp        0      0 :::111                      :::*
udp        0      0 fe80::8bf:7fff:fe9f:bd1b:123 :::*
udp        0      0 ::1:123                     :::*
udp        0      0 :::123                      :::*
udp        0      0 :::935                      :::*

Code: Select all

[root@ip-10-0-2-185 ec2-user]# nc -vz -u 10.0.2.186 4803
Connection to 10.0.2.186 4803 port [udp/notateit-disc] succeeded!
[root@ip-10-0-2-185 ec2-user]# nc -vz -u 10.0.2.184 4803
Connection to 10.0.2.184 4803 port [udp/notateit-disc] succeeded!
But i am getting following error while running vnetpref

Code: Select all

[dbadmin@ip-10-0-2-184 ~]$/opt/vertica/bin/vnetperf
2016-08-02_13:10:28,619 ERROR: [Connector Thread 10.0.2.186 0x7fe59578e700] Couldn't connect to 10.0.2.186 (family 2, attempt 0): Connection timed out; errno=110 (Connection timed out)
2016-08-02_13:10:28,619 ERROR: [Connector Thread 10.0.2.185 0x7fe59618f700] Couldn't connect to 10.0.2.185 (family 2, attempt 0): Connection timed out; errno=110 (Connection timed out)
2016-08-02_13:11:32,619 ERROR: [Connector Thread 10.0.2.186 0x7fe59578e700] Couldn't connect to 10.0.2.186 (family 2, attempt 1): Connection timed out; errno=110 (Connection timed out)
2016-08-02_13:11:32,619 ERROR: [Connector Thread 10.0.2.185 0x7fe59618f700] Couldn't connect to 10.0.2.185 (family 2, attempt 1): Connection timed out; errno=110 (Connection timed out)
2016-08-02_13:12:36,619 ERROR: [Connector Thread 10.0.2.186 0x7fe59578e700] Couldn't connect to 10.0.2.186 (family 2, attempt 2): Connection timed out; errno=110 (Connection timed out)
2016-08-02_13:12:36,619 ERROR: [Connector Thread 10.0.2.185 0x7fe59618f700] Couldn't connect to 10.0.2.185 (family 2, attempt 2): Connection timed out; errno=110 (Connection timed out)
2016-08-02_13:12:37,619 ERROR: [Connector Thread 10.0.2.186 0x7fe59578e700] Could not find anything to connect to for 10.0.2.186; errno=110 (Connection timed out)
2016-08-02_13:12:37,619 ERROR: [Connector Thread 10.0.2.185 0x7fe59618f700] Could not find anything to connect to for 10.0.2.185; errno=110 (Connection timed out)
2016-08-02_13:12:37,619 ERROR: [main 0x7fe596b92720] Caught error: Unable to connect to host 10.0.2.185:14159
Unable to connect to host 10.0.2.186:14159; errno=0 (Success)

Do i also have to open port 14159 specifically? Am i making some obvious mistake?
Please do let me know if you need any other specific information.

User avatar
JimKnicely
Site Admin
Site Admin
Posts: 1823
Joined: Sat Jan 21, 2012 4:58 am
Contact:

Re: Error while creating database in a 3-node cluster.

Post by JimKnicely » Sat Sep 24, 2016 4:24 am

Jim Knicely

Image

Note: I work for Vertica. My views, opinions, and thoughts expressed here do not represent those of my employer.

Post Reply

Return to “Vertica Database Administration”