VM - Your CPU does not support long mode. Use a 32bit distribution.

Moderator: NorbertKrupa

Post Reply
emery5309
Newbie
Newbie
Posts: 3
Joined: Tue Apr 07, 2015 1:18 pm

VM - Your CPU does not support long mode. Use a 32bit distribution.

Post by emery5309 » Tue Apr 28, 2015 7:51 pm

Hi,

I am trying to the Vertica OVF file from the my.vertica.com web site on a new laptop using Oracle VirtualBox. When I start the VM, I get this error during the boot up process:

"Your CPU does not support long mode. Use a 32bit distribution."

What does that mean?

User avatar
JimKnicely
Site Admin
Site Admin
Posts: 1768
Joined: Sat Jan 21, 2012 4:58 am
Contact:

Re: VM - Your CPU does not support long mode. Use a 32bit distribution.

Post by JimKnicely » Tue Apr 28, 2015 10:04 pm

Ha! I had/am having the same issue! You most likely need to enable "Intel Virtualization Technology (vt-x)" in the computer BIOS...
Jim Knicely

Image

Note: I work for HPE. My views, opinions, and thoughts expressed here do not represent those of my employer.

NorbertKrupa
GURU
GURU
Posts: 527
Joined: Tue Oct 22, 2013 9:36 pm
Location: Chicago, IL
Contact:

Re: VM - Your CPU does not support long mode. Use a 32bit distribution.

Post by NorbertKrupa » Wed Apr 29, 2015 3:23 am

You're both using an image from Vertica?
Checkout vertica.tips for more Vertica resources.

User avatar
JimKnicely
Site Admin
Site Admin
Posts: 1768
Joined: Sat Jan 21, 2012 4:58 am
Contact:

Re: VM - Your CPU does not support long mode. Use a 32bit distribution.

Post by JimKnicely » Wed Apr 29, 2015 3:47 am

Yeah, I am using the VM per the vertica-esx4-7.1.1-0.64 file downloaded from my.vertica.com. I’ve used it many, many times :)

For a 64-Bit guest in VirtualBox to run, Intel VT-x extensions must be enabled.

See:
http://superuser.com/questions/310739/o ... t-your-cpu

The laptop I am trying to install it on has Vt-x disabled... and I do not have rights to change BIOS settings :(

Note: You can use the MS Hardware-Assisted Virtualization Detection Tool provided in the link below to check if Virtualization is enabled:

https://www.microsoft.com/en-us/downloa ... spx?id=592
Jim Knicely

Image

Note: I work for HPE. My views, opinions, and thoughts expressed here do not represent those of my employer.

NorbertKrupa
GURU
GURU
Posts: 527
Joined: Tue Oct 22, 2013 9:36 pm
Location: Chicago, IL
Contact:

Re: VM - Your CPU does not support long mode. Use a 32bit distribution.

Post by NorbertKrupa » Wed Apr 29, 2015 3:19 pm

It might just be easier to install the VM from scratch (following the guide on vertica.tips), and have a base image that you use to install different Vertica rpm's.
Checkout vertica.tips for more Vertica resources.

Post Reply

Return to “Vertica Installation”